Linux compat oddness

Daniel O'Connor doconnor at
Thu Sep 22 06:09:57 PDT 2005

I'm trying to get the Xilinx Webpack tools running under FreeBSD..

I downloaded a bunch of RH Enterprise RPMs for the libraries it needs (
for the installer anyway) but I am stuck now with..

[inchoate 22:21] /tmp/Xilinx >/compat/linux/bin/env LD_LIBRARY_PATH=/tmp/Xilinx/lib:/tmp/Xilinx/usr/X11R6/lib:/tmp/Xilinx/usr/lib:/tmp/Xilinx/platform/lin/bin/lin /tmp/Xilinx/platform/lin/xilsetup
/tmp/Xilinx/platform/lin/xilsetup: error while loading shared libraries: /usr/lib/ ELF file OS ABI invalid

Which isn't suprising since is a FreeBSD binary..

I've branded the xilsetup binary, and even tried setting the fallback branding
to 3 but it gives the same result.

Anyone know why?

Daniel O'Connor software and network engineer
for Genesis Software -
"The nice thing about standards is that there
are so many of them to choose from."
  -- Andrew Tanenbaum
GPG Fingerprint - 5596 B766 97C0 0E94 4347 295E E593 DC20 7B3F CE8C
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list