atapicam not working under -CURRENT

Joe Marcus Clarke marcus at FreeBSD.org
Sat Sep 10 13:10:14 PDT 2005


I have a desktop machine running recent -CURRENT on which atapicam does
not work.  That is to say, applications that try to access the CD-ROM
using CAM fail claiming it's a non-MMC unit, for example.  For example,
growisofs reports:

GET CONFIGURATION failed with SK=5h/ASC=20h/ACQ=00h

cdrecord reports:

Warning: controller returns wrong size for CD capabilities page

I have tried DMA and non-DMA modes, but neither work.  This drive has
not worked under atapicam for as long as I can remember.  Here is the
link to the verbose dmesg output including the errors seen at boot-time
when a disc is inserted into the drive:

http://www.marcuscom.com/downloads/jclarke-pc_dmesg.txt

Any help would be appreciated.  Thanks.

Joe

-- 
Joe Marcus Clarke
FreeBSD GNOME Team      ::      gnome at FreeBSD.org
FreeNode / #freebsd-gnome
http://www.FreeBSD.org/gnome
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: This is a digitally signed message part
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20050910/b9ef7566/attachment.bin


More information about the freebsd-current mailing list