6.0-CURRENT SNAP004 hangs on amr (patch)

Eric Anderson anderson at centtech.com
Sat Sep 3 21:06:28 PDT 2005


Joao Barros wrote:
> On 8/8/05, John Baldwin <jhb at freebsd.org> wrote:
> 
>>Ok, so I'm assuming that 5.4 works but RELENG_6 does not?  Do you have verbose
>>dmesg's from both cases so that I can compare them?
> 
> 
> Ok, review:
> FreeBSD5.4: kernel boots with amr installed
> FreeBSD6.0: kernel doesn't boot with amr installed
> As I think some commit in time between 5.4 and CURRENT(6.0) changed
> something that prevents the kernel to boot with an amr installed, I'm
> trying to pinpoint that change.
> So far I've tested 5.4-STABLE-SNAP006-i386 which boots and back till
> 6.0-CURRENT-SNAP001 which does not boot.
> My next step will be to cvsup to specific times and start testing kernels :)
> More feedback to come!

If you verbose boot, do you see it attempting to probe (?) lots of scsi 
id's that don't exist?    I have an issue with a QLogic fiber channel 
card doing this on 6.0-B3 but not on the most recent 5.4-STABLE.   It's 
definitely something in CAM that isn't right.  If anyone wants more 
info, I'd be happy to provide it.

Eric


-- 
------------------------------------------------------------------------
Eric Anderson        Sr. Systems Administrator        Centaur Technology
Anything that works is better than anything that doesn't.
------------------------------------------------------------------------


More information about the freebsd-current mailing list