Non working keyboard in X11 after upgrade of basesystem

Vladimir Timofeev vovkasm at
Wed Dec 28 07:31:05 PST 2005

Seems like this

2005/12/28, Alexander Leidinger <Alexander at>:
> Hi,
> I've upgraded my Laptop from a beginning of December -current to a 24.
> December -current. After a reboot I wasn't able to use the keyboard in
> X11 anymore (kbd driver). The NumLock and the like functionality works
> in X11 (the leds are activated and deactivated as expected), but I
> don't see characters appearing in the gdm login window when I type
> something. The <ctrl>+<alt>+<backspace> X-server reset doesn't work
> too, so I think X11 doesn't sees any input.
> I tried to update to xorg-server-snap at 25. December, but this didn't
> solved the problem. Still no working keyboard. I can't find any strange
> looking message in the logs of the X-server which could explain this,
> everything looks sane.
> Then I updated to a 27. December -current. Still no working keyboard in
> X11 (console works as expected, but I have to boot into single-user
> mode, since I'm not able to switch to the console when X11 starts with
> a normal boot).
> I really updated the basesystem only on 24. December.
> Does this sound familiar to someone? Any ideas what I could try to find
> the cause of the problem? I update the source from a local repository
> with CVS, but there's only a slow wireless connection, so it would take
> very long to do a binary search of the change in -current which
> resulted in this change.
> Can this be related to the recent symbol versioning commits and I need
> to rebuild the X11-libs?
> Bye,
> Alexander.
> --
>                       Alexander @
>   GPG fingerprint = C518 BC70 E67F 143F BE91  3365 79E2 9C60 B006 3FE7
> _______________________________________________
> freebsd-current at mailing list
> To unsubscribe, send any mail to "freebsd-current-unsubscribe at"

More information about the freebsd-current mailing list