-BETA2 and Thunder K8WE

Michael Sinatra michael at rancid.berkeley.edu
Fri Aug 19 16:13:49 GMT 2005



On Fri, 19 Aug 2005, Damian Gerow wrote:

> I just tried booting 6.0-BETA2 on a Tyan Thunder K8WE, to no success.
> Even with the on-board SCSI disabled, the system hangs after probing mpt0:
> it does the SCSI device settle delay[1], picks up the SATA drives, then
> hangs.  Under a 'boot -v', I get a whole bunch of cruft about detecting
> devices on mpt0.  The system fully freezes after it's done, though, so I
> can't really pull much data from the dmesg.
>
> I've tried booting with and without SCSI enabled, to the same effect.  I
> haven't yet tried booting without ACPI, as the last time I tried that, the
> system didn't pick up any drives at all.

I have had the same problem; however, it does not hang when I disable the 
onboard MPT scsi in the BIOS.  I have another Thunder K8WE that works 
pretty well, but I had to do all sorts of disablings and tweakings in the 
BIOS to get it to boot with SCSI still enabled.  I'll have to check, but I 
also think that is running an earlier version of the BIOS.  I haven't 
found any way to get the current (1.01) version of the BIOS to boot 
without disabling SCSI.  Unfortunately, this particular box comes with a 
nice SCSI disk array.

You might try enabling bus master on the SCSI and disabling the onboard 
nvidia ethernets (looks like the nve(4) driver is still a bit buggy 
anyway.  The intel pro 1000 pci-x card works great using the em(4) driver, 
and a dual-opteron machine running 6-STABLE pushes line rate gig over 
short delay distances; haven't tested yet over larger bandwidth*delay 
product links.  Using the intel instead of the onboard nvidia and enabling 
bus master on the SCSI allowed me to boot _one_ of the machines and I have 
6-STABLE running on it.  I haven't quite done enough research to figure 
out why, but I will try looking into it later today.

michael



More information about the freebsd-current mailing list