dhclient problems

Beecher Rintoul akbeech at gmail.com
Fri Aug 12 20:11:33 GMT 2005

On Friday 12 August 2005 08:28 am, Brooks Davis wrote:
> On Thu, Aug 11, 2005 at 10:39:23PM -0800, Beecher Rintoul wrote:
> > On Thursday 11 August 2005 05:05 pm, you wrote:
> > > On Thu, Aug 11, 2005 at 05:02:15PM -0800, Beecher Rintoul wrote:
> > > > I'm having problems with the new dhclient not returning the gateway
> > > > on my wireless card. I reinstalled isc-dhclient and the probs went
> > > > away. My question is there a knob such as "NO_DHCLIENT" I can put in
> > > > make.conf?
> > >
> > > No.  Care to help improve freebsd by providing some debugging info?
> > > You're server is presumably doing something dhclient isn't expecing
> > > which is causing it to reject the gateway.  If we could find out what
> > > it is we could fix it.
> >
> > As much as i would like to... it's a new machine for a client in a VERY
> > micro$oft oriented business. He likes FreeBSD with the KDE suite and
> > replaced his desktop out of his own pocket. The box is a MSI 8-T with a
> > 2800+ Athlon. I needed to install ndis for a D-Link AG-350, so I had 7.0
> > on the box. The box would hang on boot at dhclient, then return
> > for the router addy. (the IP and DNS were correct). Killing and
> > restarting dhclient would finally get the proper gateway. I tried the box
> > at home and it worked, but would hang about 30 seconds on boot at
> > dhclient. After going back to isc-dhcp, I just reinstalled  5-STABLE
> > (stock) and all the problems went away. I'm not sure if the problem was
> > dhclient or ndis related, but I don't have a supported card, or easy
> > access to the machine to troubleshoot any further. BTW, the ndis driver
> > works very well with that card running 5.4. I have the same card at home
> > running -CURRENT on an old HP, and have had no dhclient problems.
> By any chance, was defaultrouter set in /etc/rc.conf (possiably as a
> side effect of initial configuration?)  If so, that might be the cause
> since dhclient was modified to only touch the default route if the
> route is on the same interface as dhclient.
No, since this was a standalone workstation I didn't have defaultrouter set in 
rc.conf. At the point I was having probs, I even cleaned out resolv.conf, 
hosts, dhclient.leases.ndis0 and tried a reboot. The only custom stuff was 
ifconfig_ndis0="DHCP" in rc.conf and ifconfig ndis0 ssid company (no WEP) 
in /etc/start_if.ndis0. The exact same configuration worked perfectly when I 
went to 5.4. I did however notice that I had a bogus defaultrouter setting on 
my home box running -CURRENT, but it doesn't cause any problems (I removed 
the line anyway).

Beech Rintoul - System Administrator - akbeech at gmail.com
/"\   ASCII Ribbon Campaign  | NorthWind Communications
\ / - NO HTML/RTF in e-mail  | 201 East 9th Avenue Ste.310
 X  - NO Word docs in e-mail | Anchorage, AK 99501
/ \ 

More information about the freebsd-current mailing list