Portupgrade, -CURRENT & SMP

Sean rsh.lists at comcast.net
Mon Aug 8 22:30:33 GMT 2005


Adam K Kirchhoff wrote:
> 
> I have three machines which I just upgraded from 5.4 to -CURRENT.  They 
> are two SMP desktops and a UP laptop.
> 
> After building world and installing, I started to run portupgrade on my 
> systems.  On the laptop, everything has been running smoothly..  On both 
> SMP systems, portupgrade hangs.  top shows the ruby18 process stuck in 
> the *vnode state.  On one machine, which I can't physically access, it's 
> been this way for hours.  I can't ssh into this machine, and only have 
> access to sessions that were connected before the hang.  On my home 
> machine (which I can physically access), I've been able to log in on the 
> virtual consoles and reboot when this happens (though it's not ever able 
> to sync all buffers and cleanly unmount /).  It's now happened with 5 or 
> 6 consecutive attempts at portupgrade on this machine.  The most recent 
> time this happened, on a hunch, I built a UP kernel, rebooted, and tried 
> portupgrade again.  It's now been running for two hours without hanging 
> (previous record was less than five minutes).
> 
> I've googled around a bit for this problem, but haven't come across 
> anythign yet.  Has anyone seen this before?  I'll gladly submit a pr, 
> but I'm just looking for more idea, or maybe some confirmation from 
> others who have seen this.
> 
> Adam
> 
> _______________________________________________
> freebsd-current at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-current
> To unsubscribe, send any mail to "freebsd-current-unsubscribe at freebsd.org"
> 
Hi Adam,

	Using an old kernel I cvsup'd my system to
uname -a
FreeBSD tardis.mydomain.net 7.0-CURRENT FreeBSD 7.0-CURRENT #0: Mon Aug 
  8 06:25:58 EDT 2005
and portupgrade is no longer hanging on my SMP system.

				Sean


More information about the freebsd-current mailing list