amd64 buildworld broken ...

Pascal Hofstee caelian at gmail.com
Fri Aug 5 22:59:28 GMT 2005


On Fri, 2005-08-05 at 09:50 -0700, Pascal Hofstee wrote:
> I had some strange network problems yesterday so i am not sure if my
> mail actually made it out to the list (since i have seen no responses at
> all yet .. i assume it did not ... so i retry).
> 
> I have tried a buildworld for 7.0-CURRENT/amd64 for three days straight
> now .. and it keeps bailing out with the following error.

[snip]

> I have tried make cleanworld, rm -Rf /usr/src, using different cvsup
> mirrors yet the problem persists. if below's snippet of output log is
> insufficient i can provide a full buildworld log if required.

Well .. it looks like make cleanworld doesn't clean up /usr/obj/lib32 so
after manually issuing an "rm -Rf /usr/obj/lib32" buildworld still
breaks .. but in a different location now.

===> lib/csu/i386-elf (depend,all,install)
rm -f .depend
mkdep -f .depend -a    -I/usr/src/lib/csu/i386-elf/../common
-I/usr/src/lib/csu/i386-elf/../../libc/include /usr/src/lib/csu/i386-elf/crt1.c /usr/src/lib/csu/i386-elf/crti.S /usr/src/lib/csu/i386-elf/crtn.S
cc -O -g -pipe -I/usr/src/lib/csu/i386-elf/../common
-I/usr/src/lib/csu/i386-elf/../../libc/include -Wsystem-headers -Werror
-Wall -Wno-format-y2k -W -Wno-unused-parameter -Wstrict-prototypes
-Wmissing-prototypes -Wpointer-arith -Wreturn-type -Wcast-qual
-Wwrite-strings -Wswitch -Wshadow -Wcast-align -Wunused-parameter
-Wchar-subscripts -Winline -Wnested-externs -Wredundant-decls
-c /usr/src/lib/csu/i386-elf/crt1.c
{standard input}: Assembler messages:
{standard input}:74: Error: suffix or operands invalid for `mov'
*** Error code 1

Stop in /usr/src/lib/csu/i386-elf.
*** Error code 1

Can somebody on amd64 HEAD .. please confirm this breakage or give me
suggestions on what else i can possibly try to resolve this buildworld
problem ?

-- 
  Pascal Hofstee




More information about the freebsd-current mailing list