amd64 buildworld broken ...

Pascal Hofstee caelian at gmail.com
Fri Aug 5 16:50:48 GMT 2005


I had some strange network problems yesterday so i am not sure if my
mail actually made it out to the list (since i have seen no responses at
all yet .. i assume it did not ... so i retry).

I have tried a buildworld for 7.0-CURRENT/amd64 for three days straight
now .. and it keeps bailing out with the following error.

It looks like somehow "MACHINE=i386  MACHINE_ARCH=i386" are not getting
properly set during the building of the following lib32 bits. Can
somebody please confirm this breakage ... as i haven't seen the
tinderboxes complain yet. (I have no NO_* settings or TARGET_ARCH
specifications in my make.conf).

I have tried make cleanworld, rm -Rf /usr/src, using different cvsup
mirrors yet the problem persists. if below's snippet of output log is
insufficient i can provide a full buildworld log if required.


===> kerberos5/lib/libasn1 (depend,all,install)
building shared library libasn1.so.8
/usr/obj/usr/src/tmp/usr/bin/ld: warning: i386 architecture of input
file `asn1_err.So' is incompatible with i386:x86-64 output
asn1_err.So(.text+0x33): In function `initialize_asn1_error_table_r':
/usr/obj/lib32/usr/src/kerberos5/lib/libasn1/asn1_err.c:26: undefined
reference to `initialize_error_table_r'
asn1_err.So(.text+0x6c): In function `initialize_asn1_error_table':
/usr/obj/lib32/usr/src/kerberos5/lib/libasn1/asn1_err.c:31: undefined
reference to `init_error_table'
*** Error code 1

Stop in /usr/src/kerberos5/lib/libasn1.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.


-- 
  Pascal Hofstee





More information about the freebsd-current mailing list