Low volume sound on Dell Precision 530 (snd_ich)

Ryan Freeman ryan at slipgate.org
Mon Sep 27 23:10:03 PDT 2004


On Tue, Sep 28, 2004 at 04:07:12PM +1000, Jan Mikkelsen wrote:
> Daniel O'Connor wrote:
> > On Mon, 27 Sep 2004 16:27, 
> > janm-freebsd-current at transactionware.com wrote:
> > > Hi,
> > >
> > > I've just started running RELENG_5 after having run 
> > RELENG_4 for a while.
> > >
> > > After upgrading to 5.3-BETA3 (fresh install from ISO), the 
> > sound volume is
> > > very low.  Running recent sources doesn't change things.
> > >
> > > I did have a similar problem with RELENG_4, but I could 
> > work around it by
> > > explicitly loading snd_ich rather than snd_pcm.  
> > Unfortunately, that isn't
> > > helping with 5.3-BETA.
> > >
> > > This is a Dell Precision 530 with an i860 chipset.
> > >
> > > Has anyone seen this before?  Any suggestions?
> > 
> > Try fiddling with the mixer settings?
> > 
> > eg..
> > mixer pcm 100
> > mixer ogain 100
> > mixer vol 100
> 
> Thanks.
> 
> Only "mixer ogain" and "mixer pcm" change the actual volume on this machine.
> "mixer cd" does affect CD playback volume, but I need to increase ogain from
> the default 50:50 to get an acceptable volume.

hmm, are you playing cds through xmms? and if so, if you're using digital
extraction rather than analog playback, then yes changing cd volume won't 
change anything. if you'd rather use analog (or like to check, i think its
default to digital extraction) hope this makes things a little less mysterious!

- ryan



More information about the freebsd-current mailing list