Fatal error 'Spinlock called when not threaded.' ... (Re:FreeBSD 5.3-BETA6 available)

Scott Long scottl at FreeBSD.org
Sun Sep 26 14:35:26 PDT 2004

Andreas Klemm wrote:
> Hi,
> don't know if this a a local problem, but during the last OS update
> by "make world" I suddenly couldn't re-login under X11 (screen saver
> locked screen and I couldnt sucessfully re-login).
> Ctrl-ALT-BS helped, shutdown of X11, then reboot.
> But then I was unable to start X11 because kdeinit couldn't startup.
> With other window manager no problem.
> Error message is some problem with kdeinit to "connect:".
> Now I assumed an error with kdelibs and deinstalled kdelibs3
> and tried to reinstall.
> kdelibs3 cannot be re-compiled because of an error during compilation.
> I re-cvsupped, made world again, reboot and now I'm trying to 
> recompile kdelibs3 a 2nd time, same error at same location.

You are probably mixing libc_r and libpthread somewhere.  Use
/etc/libmap.conf to map libc_r over to libpthread.  The best long-term
solution is to recompile all of your ports.


More information about the freebsd-current mailing list