Fatal error 'Spinlock called when not threaded.' ... (Re: FreeBSD 5.3-BETA6 available)

Andreas Klemm andreas at freebsd.org
Sun Sep 26 14:30:11 PDT 2004


don't know if this a a local problem, but during the last OS update
by "make world" I suddenly couldn't re-login under X11 (screen saver
locked screen and I couldnt sucessfully re-login).
Ctrl-ALT-BS helped, shutdown of X11, then reboot.

But then I was unable to start X11 because kdeinit couldn't startup.
With other window manager no problem.
Error message is some problem with kdeinit to "connect:".

Now I assumed an error with kdelibs and deinstalled kdelibs3
and tried to reinstall.

kdelibs3 cannot be re-compiled because of an error during compilation.

I re-cvsupped, made world again, reboot and now I'm trying to 
recompile kdelibs3 a 2nd time, same error at same location.

ogmanager.lo -MD -MP -MF ".deps/kconfigdialogmanager.Tpo" -c -o kconfigdialogman
ager.lo kconfigdialogmanager.cpp; \
then mv -f ".deps/kconfigdialogmanager.Tpo" ".deps/kconfigdialogmanager.Plo"; el
se rm -f ".deps/kconfigdialogmanager.Tpo"; exit 1; fi
if /bin/sh ../libtool --silent --mode=compile --tag=CXX c++ -DHAVE_CONFIG_H -I.
-I. -I.. -I../dcop -I../kio/kssl -I../kdefx -I../kdecore/network -I../dcop -I../
libltdl -I../kdefx -I../kdecore -I../kdeui -I../kio -I../kio/kio -I../kio/kfile
-I..  -I/usr/X11R6/include -I/usr/local/include -I/usr/local/include -I/usr/loca
l/include/libart-2.0  -DQT_THREAD_SUPPORT   -I/usr/local/include -I/usr/local/in
clude  -I/usr/X11R6/include -D_GETOPT_H -D_THREAD_SAFE   -Wnon-virtual-dtor -Wno
-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG
-O2 -pipe -O -fno-exceptions -fno-check-new -fno-common  -DQT_CLEAN_NAMESPACE -D
o -MD -MP -MF ".deps/klockfile.Tpo" -c -o klockfile.lo klockfile.cpp; \
then mv -f ".deps/klockfile.Tpo" ".deps/klockfile.Plo"; else rm -f ".deps/klockf
ile.Tpo"; exit 1; fi
../dcop/dcopidl/dcopidl ./ksycoca.h > ksycoca.kidl || ( rm -f ksycoca.kidl ; fal
se )
Fatal error 'Spinlock called when not threaded.' at line 83 in file /usr/src/lib
/libpthread/thread/thr_spinlock.c (errno = 0)
Abort trap (core dumped)
gmake[3]: *** [ksycoca.kidl] Error 1
gmake[3]: Leaving directory `/usr/ports/x11/kdelibs3/work/kdelibs-3.3.0/kdecore'

Somebody else with similar behaviour after upgrading to BETA-6 ?

Need a magic printfilter today ? -> http://www.apsfilter.org/

More information about the freebsd-current mailing list