usb hub disconnect crashes 5.3-BETA4 hard

David Gilbert dgilbert at dclg.ca
Thu Sep 16 14:46:14 PDT 2004


I have two different USB mice.  One is a little portable one that has
a wireless "dongle" that pluggs into the port.  This one works fine.

The second is an MX-900 (Logitec) that is a "bluetooth" mouse... but
the unit itself shows up as a USB hub and a usb mouse in that hub.
This (I believe) is due to the fact that the "base station" is
emulating a usb mouse ... but also has the ability to show up as a
bluetooth receiver (if you enable it).  That function is not enabled
on my mouse --- so it shows up as hub with a mouse attached to the
hub.

When the hub/mouse is unplugged, FreeBSD-5.3-BETA4 panic's hard but
BETA2 did not.  This may be a false hope ... I think I have seen this
before, but I don't remember exactly.

When it panics hard, I see "ums0 detached" (bright text) followed by
"(null) at uhub4 <something something>" followed by a panic message an
no dump.

Here is the kernel messages for the working mouse:

[3:2:302]dgilbert at canoe:~> dmesg | grep -i usb
uhci0: <Intel 82801DB (ICH4) USB controller USB-A> port 0xbf80-0xbf9f irq 11 at device 29.0 on pci0
usb0: <Intel 82801DB (ICH4) USB controller USB-A> on uhci0
usb0: USB revision 1.0
uhci1: <Intel 82801DB (ICH4) USB controller USB-B> port 0xbf40-0xbf5f irq 11 at device 29.1 on pci0
usb1: <Intel 82801DB (ICH4) USB controller USB-B> on uhci1
usb1: USB revision 1.0
uhci2: <Intel 82801DB (ICH4) USB controller USB-C> port 0xbf20-0xbf3f irq 11 at device 29.2 on pci0
usb2: <Intel 82801DB (ICH4) USB controller USB-C> on uhci2
usb2: USB revision 1.0
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xf4fffc00-0xf4ffffff irq 11 at device 29.7 on pci0
ehci_pci_attach: companion usb0
ehci_pci_attach: companion usb1
ehci_pci_attach: companion usb2
usb3: EHCI version 1.0
usb3: companion controllers, 2 ports each: usb0 usb1 usb2
usb3: <EHCI (generic) USB 2.0 controller> on ehci0
usb3: USB revision 2.0
ums0: PATEN USB Receiver, rev 1.10/1.03, addr 2, iclass 3/1
ums0: PATEN USB Receiver, rev 1.10/1.03, addr 2, iclass 3/1

Here are the kernel messages for the mouse attaching (obviously I
can't show the exact detatch messages):

uhub4: Texas Instruments General Purpose USB Hub, class 9/0, rev 1.10/1.01, addr 3
uhub4: 2 ports with 0 removable, bus powered
ums1: Logitech USB Receiver, rev 1.10/27.04, addr 4, iclass 3/1
ums1: 7 buttons and Z dir.

Dave.

-- 
============================================================================
|David Gilbert, Independent Contractor.       | Two things can only be     |
|Mail:       dave at daveg.ca                    |  equal if and only if they |
|http://daveg.ca                              |   are precisely opposite.  |
=========================================================GLO================


More information about the freebsd-current mailing list