[PATCH] Clie TH55 sync over usb (maybe other OS 5 devices too)

Brian Fundakowski Feldman green at freebsd.org
Wed Sep 8 16:49:17 PDT 2004


On Wed, Sep 08, 2004 at 02:44:37AM -0500, Axel Gonzalez wrote:
> 
> Finally got my TH55 to hotsync with pilot-link.
> 
> There was a couple issues:
> 
> * It doesn't like the 'getting connection info' part, it just timed out. After 
> removing it, attach/detach work fine (don't know if its needed for other 
> devices, so in the patch I don't remove it.. my m505 works ok with this 
> code).
> It was the same problem as described on this thread:
> http://lists.freebsd.org/pipermail/freebsd-current/2004-August/033438.html
> 
> so maybe this will work for other devices too.
> 
> 
> * This device uses 2 pairs of bulk ports, uses first pair for 'in', second for 
> 'out'. You need to map the correct addresses in order to work (got a hint for 
> a little bird on this one).
> 
> 
> After this couple fixes (and adding id's for the device), it works just fine.

Please look at this thread and tell me if it applies similarly to you.
I would need to un-delete Clie 3.5 support before I committed it, of course.

	Message-ID: <20040701154429.GA3543 at tomcat.kitchenlab.org>

-- 
Brian Fundakowski Feldman                           \'[ FreeBSD ]''''''''''\
  <> green at FreeBSD.org                               \  The Power to Serve! \
 Opinions expressed are my own.                       \,,,,,,,,,,,,,,,,,,,,,,\


More information about the freebsd-current mailing list