5.3-BETA7 ata problem with VIA 8235

John Hay jhay at icomtek.csir.co.za
Fri Oct 8 05:52:22 PDT 2004


On Fri, Oct 08, 2004 at 02:22:53PM +0200, Patrick M. Hausen wrote:
> Hi!
> 
> Next test with the current beta:
> 
> We have a system with a VIA chipset based mainboard, the ATA
> controller is reported to be a VIA 8235.
> This system has worked just fine with 5.1 then stopped working when
> the atang changes were commited. It wasn't that important to us
> (it's really cheap [tm] hardware), but since I'm doing some tests
> with the current beta anyway and there were various ata fixes
> announced:
> 
> Boot from miniinst.iso:
> 
> ...
> atapci0: <VIA 8235 UDMA133 controller> port 0xdc00-0xdc0f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at deviec 17.1 on pci0
> ata0: channel #0 on atapci0
> ata1: channel #1 on atapci0
> ...
> ata0-master: FAILURE - ATA_IDENTTIFY timed out
> ...
> ata1-master: FAILURE - ATAPI_IDENTIFY timed out
> ...
> 
> With most systems I tried before (5.2.1-RELEASE, previous 5.3-BETAs) the
> system just hung without a clear error message after loading md0.

Try disabling the apic. Break out of the loader by pressing '6' and then
type:
set hint.apic.0.disabled=1
boot

We have two Asus P4VP-MX motherboards with that chipset. I think the
apic is initialized too late or something. If you do a verbose boot
without disabling the apic, you see apic messages after ata failed.

John
-- 
John Hay -- John.Hay at icomtek.csir.co.za / jhay at FreeBSD.org


More information about the freebsd-current mailing list