5.3-BETA7 ata problem with VIA 8235

Patrick M. Hausen hausen at punkt.de
Fri Oct 8 05:22:55 PDT 2004


Hi!

Next test with the current beta:

We have a system with a VIA chipset based mainboard, the ATA
controller is reported to be a VIA 8235.
This system has worked just fine with 5.1 then stopped working when
the atang changes were commited. It wasn't that important to us
(it's really cheap [tm] hardware), but since I'm doing some tests
with the current beta anyway and there were various ata fixes
announced:

Boot from miniinst.iso:

...
atapci0: <VIA 8235 UDMA133 controller> port 0xdc00-0xdc0f,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at deviec 17.1 on pci0
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
...
ata0-master: FAILURE - ATA_IDENTTIFY timed out
...
ata1-master: FAILURE - ATAPI_IDENTIFY timed out
...

With most systems I tried before (5.2.1-RELEASE, previous 5.3-BETAs) the
system just hung without a clear error message after loading md0.


Any ideas?
Thanks,
Patrick
-- 
punkt.de GmbH         Internet - Dienstleistungen - Beratung
Vorholzstr. 25        Tel. 0721 9109 -0 Fax: -100
76137 Karlsruhe       http://punkt.de


More information about the freebsd-current mailing list