5.3 kernel panic: ufs_dirbad during installation

Dennis Koegel amf at hobbit.neveragain.de
Tue Nov 9 03:47:22 PST 2004


I tried to install 5.3-RELEASE from a freshly downloaded miniinst.iso
yesterday. Target: old PII/233 with 64mb. HDD being a Maxtor IDE 4gb
which I told sysinstall to use completely.

When sysinstall does newfs, the kernel panics: ufs_dirbad, "mangled
entry". Tried again, same story.

Wiping the first some k blocks of the disk (with dd) didn't help either.

Same HDD, this time in a PIII/600, 288mb (home-built 5.3 world and
custom kernel): Manually newfs(8)d, worked fine. Mounted on /mnt,
smooth. Now doing a mkdir /mnt/usr kills the system with the same panic.

The only ideas found while googling was to replace a 80pin IDE cable
with a 40pin or disabling soft updates. The latter didn't change
anything and the cables used were 40p in the first place...

Unfortunately I didn't have another HDD at hand to test it, but I will
do later today.

Any ideas, hints?
(Should I PR this?)

- D.

More information about the freebsd-current mailing list