Page fault in kernel mode; unable to dump core; reproducable

Tai-hwa Liang avatar at
Wed Jun 16 14:29:58 GMT 2004

On Tue, 15 Jun 2004, Peter Schuller wrote:
> > That's what I saw on my T40. However, this only happens if I boot with a
> > GENERIC kernel instead of a custom one.
> This is a T40p, though I am not using GENERIC. I presume there is some
> specific driver/feature that is causing it, that I happen to have loaded and
> you don't.

Feel free to take a look at my dmesg output if you're interested in:

> > I'm not sure about that; however, I can get the backtrace reliably by
> > issuing a 'panic' command in DDB.
> Hmm, ok. Do I need to do anything during compilation to enable this then
> perhaps? I found some instructions Googling but those were extremely old and
> applicable to the new build system. However I then checked the handbook and I
> didn't see it mentioned.

I use following DDB related settings in the kernel configuration file:

makeoptions	DEBUG=-g
options		DDB
options		DDB_TRACE

Then a "config -g conf_file" follows the usual kernel building commands
are enough to generate a kernel with debugging symbol.

> > Perhaps this is also related to the thread "Thinkpad panic woes (was Re:
> > CDRW causes Thinkpad T41 to panic)" about two weeks ago?
> >
> >
> Maybe. While I tried the PS2 solution once, I have i enabled at the moment
> (firstly I want the CD-ROM working and secondly if Windows were to break I
> would no longer be able to boot from CD nor re-enable the drive bay).

I haven't tried the PS2 utility, yet; however, accroding to some other T40
users, detach the CD-ROM from device bay or reduce the retry counter in
ata-all.c seems like a possible workaround.

More information about the freebsd-current mailing list