Sysinstall & labels/fdisk

Doug White dwhite at
Mon Jun 7 17:46:48 GMT 2004

On Mon, 7 Jun 2004, Joan Picanyol wrote:

> * Alex Hoff <ahoff at> [20040607 16:47]:
> > I have run in to an odd problem that on a freebsd 5.2 current system after
> > running fdisk and disklabel the initial time on install, i am never allowed
> > to do it again.
> >
> > What I have tried on many different systems, is to run sysinstall, and
> > either run fdisk or label. After making a change and trying to write the
> > changes, it will fail. Even if you dont make a change, and just try to write
> > the current settings to the disk, it will fail. The following error comes up
> > "ERROR: Unable to write data to disk ad0" (if also tried different types of
> > disk devices - da/aacd). Ktrace shows the error as "errno 1 Operation not
> > permitted"
> GEOM won't let you touch MBR/slices/partitions on used devices. For it
> to allow footshooting you should set kern.geom.debugflags=16

Be REALLY careful with this!  I have a documented case of te device
entries getting confused and blowing away the wrong partition. I STRONGLY
recommend AGAINST using this flag.

Make backups, we are not responsible, etc. etc. etc.

Doug White                    |  FreeBSD: The Power to Serve
dwhite at          |

More information about the freebsd-current mailing list