5.2-CURRENT - ata1-slave : TIMEOUT - SETFEATURES - another evil continues...

Colin Harford charford-list at infinithost.com
Sat Jan 31 20:54:36 PST 2004

Hash: SHA1


I have the same problem, that the ATA probes keep dying with my 

I emailed Søren some dmesg related stuff today on it...



On 31-Jan-04, at 5:59 PM, Matt Dawson wrote:

> OK, who said it was a Lite-On problem? Go to the head of the class. I 
> just
> removed all my ATA devices, installed my (crappy) Sil0680 software 
> RAID card
> temporarily and gave each device its own IDE channel. Whatever channel 
> I put
> the Lite-On LTR-48246S onto showed the following in dmesg:
> ata1-slave: WARNING - SETFEATURES recovered from missing interrupt
> with my kernel that works, p0. This is taken, of course, from the 
> dmesg after
> I put everything back the way it was. The original message was 
> ata0-master. I
> haven't tried compiling the latest source on this machine yet, since I 
> figure
> I have to get rid of this problem before I stand a fighting chance of 
> getting
> the new ata drivers working on here.
> So it seems the LTR-48246S is the problem device. Bummer. It works 
> nicely with
> K3b and xcdroast, too. I shall upgrade to the latest firmware if I can 
> find a
> binary file of SS0E (why do these people assume we all have Windoze 
> boxes to
> upgrade firmware?) and see what happens.
> UPDATE: Nothing happened with firmware update to SS0E. Still got the 
> same
> message.
> Any ideas? Is there some way this can be worked around? Any logs, etc.
> required?
> -- 
> Matt Dawson.
> _______________________________________________
> freebsd-current at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-current
> To unsubscribe, send any mail to 
> "freebsd-current-unsubscribe at freebsd.org"
Version: GnuPG v1.2.4 (Darwin)


More information about the freebsd-current mailing list