5.2 ata and apm status on thinkpad...

Simon L. Nielsen simon at FreeBSD.org
Sat Jan 24 15:02:59 PST 2004

On 2004.01.24 22:48:22 +0000, Julian Holley wrote:
> Hi - I finally got apm working fine on my IBM TP 390X on FreeBSD4.9 -
> Great ! - but after attempting to follow the compile configure as close
> as possible for 4.9 for 5.2 I still not get apm to work with 5.2.
> My machine crashes on resume in 5.2 with the final message :-
> ad0: setting PI04 on intel PIIX4 chip
> then total lock with the disk LED on   :(

I think I saw something similar on my IBM ThinkPad R40 when I ran
5.2-RELEASE.  After I upgraded to 5.2-CURRENT susped/resume it worked

> So some where between 4.9 and 5.2 somat a bit different with apm on

5.X normally uses ACPI not APM, so that very often makes a big

> resetting the drives, anyone any idea what's changed, I haven't got any
> other versions inbetween and I'm very new to BSD so I'd grateful for any
> hints, J

If you are very new to FreeBSD I would suggest just staying with 4.9 if
that works for you.  Running -CURRENT is not recomended for new users.

Simon L. Nielsen
FreeBSD Documentation Team
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20040125/04df7dde/attachment.bin

More information about the freebsd-current mailing list