KDE stopped working after -current upgrade

mi+mx at aldan.algebra.com mi+mx at aldan.algebra.com
Mon Jan 5 06:15:42 PST 2004

On Mon, 5 Jan 2004, Mikhail Teterin wrote:

=> I had KDE running nicely since November on my dual PII. After
=> rebuilding -current on Saturday, I can not login -- seems like the
=> window manager is crashing:
=> 	pid 52040 (kdeinit), uid 105: exited on signal 6 (core dumped)
=> The only unusual thing is -- PTHREAD_LIBS is set to -lthr... I tried
=> rebuilding Qt, kdelibs, and kdebase -- still the same.

=Ports are not yet ready for switching PTHREAD_LIBS to something other
=than -lc_r. But don't let this stop you from trying to figure out which
=ports are getting confused and fixing them :-) For 5.3 we'll need to
=solve this since libkse^H^H^Hpthread will be the default.

KDE ports seem to be ready. ldd confirms, that there is no -lc_r in the
list of libraries -- only -lthr. Most importantly, it was running fine
until the upgrade. I only started rebuilding it after noticing crashes
post reboot.

So, something broke over the month of December and -lthr (or its support
in kernel) is my prime suspect.

=FYI, the problem is that some ports have configure/libtools that
=autodetect -lc_r and/or -pthread. So you may set PTHREAD_LIBS to -lthr
=(or -lkse), but you'll end up linking to both -lthr and -lc_r. Use ldd
=on the libraries/binaries and you'll see what I mean.

Yes, I know. I went through that in November :-)


More information about the freebsd-current mailing list