KDE stopped working after -current upgrade

Peter Schultz pmes at bis.midco.net
Mon Jan 5 03:58:34 PST 2004

Daniel Eischen wrote:
> On Mon, 5 Jan 2004, Mikhail Teterin wrote:
>>I had KDE running nicely since November on my dual PII. After rebuilding
>>-current on Saturday, I can not login -- seems like the window manager
>>is crashing:
>>	pid 52040 (kdeinit), uid 105: exited on signal 6 (core dumped)
>>The only unusual thing is -- PTHREAD_LIBS is set to -lthr... I tried
>>rebuilding Qt, kdelibs, and kdebase -- still the same.
>>Any ideas? Thanks!
> Ports are not yet ready for switching PTHREAD_LIBS to something
> other than -lc_r.  But don't let this stop you from trying
> to figure out which ports are getting confused and fixing
> them :-)  For 5.3 we'll need to solve this since libkse^H^H^Hpthread
> will be the default.
> FYI, the problem is that some ports have configure/libtools
> that autodetect -lc_r and/or -pthread.  So you may set
> PTHREAD_LIBS to -lthr (or -lkse), but you'll end up linking
> to both -lthr and -lc_r.  Use ldd on the libraries/binaries
> and you'll see what I mean.
I set PTHREAD_LIBS=-lkse in /etc/make.conf since November and up until 
Friday I had no problems.  The java plug-in has been acting up on me, 
however.  I'm hoping for a 5.2-RELEASE soon so that I can do a nice 
clean install of everything.


More information about the freebsd-current mailing list