Help making sense of firewire disk enclosure dilema

Doug White dwhite at
Sun Aug 22 19:40:38 PDT 2004

On Sat, 21 Aug 2004, George Hartzell wrote:

> I have a machine running 5.2.1-RELEASE-p6.
> I purchased a pair of "Vantec" USB2.0/Firewire enclosures (NST-350UF)
> for some 80-ish GB IBM Deskstar drives.
> The first enclosure worked great (once I got past the kernel panic
> because it didn't like something that was hanging out in the partition
> table area).
> The second enclosure was problematic.  If I attached via USB1 (all I
> have), it worked fine.  If I hook it up to a G4 Powermac running OSX
> Jaguar (current-1?), it works fine.  But when I connect it via
> firewire to Servant, GEOM never recognizes/creates a daX device.

Have you tried 'camcontrol rescan X' where X is the appropriate SCSI bus?
(camcontrol devlist -v can help you find the right bus number.)

I have this problem with certain USB key storage devices as well. It
depends on how long the device takes to come ready.  Some are better than

Doug White                    |  FreeBSD: The Power to Serve
dwhite at          |

More information about the freebsd-current mailing list