Help making sense of firewire disk enclosure dilema

Daniel O'Connor doconnor at
Sat Aug 21 18:51:51 PDT 2004

Hash: SHA1

On Sun, 22 Aug 2004 09:53, George Hartzell wrote:
> I have a machine running 5.2.1-RELEASE-p6.
> I purchased a pair of "Vantec" USB2.0/Firewire enclosures (NST-350UF)
> for some 80-ish GB IBM Deskstar drives.
> The first enclosure worked great (once I got past the kernel panic
> because it didn't like something that was hanging out in the partition
> table area).
> The second enclosure was problematic.  If I attached via USB1 (all I
> have), it worked fine.  If I hook it up to a G4 Powermac running OSX
> Jaguar (current-1?), it works fine.  But when I connect it via
> firewire to Servant, GEOM never recognizes/creates a daX device.

We have 2 enclosures at work, both made by Mapower.
They have two different oxford semiconductor devices in them (a Firewire only 
one, and a Firewire/USB2 one).

The Firewire only one _always_ requires that it is plugged in, removed and 
plugged in again before a daX device node will appear (it says New S400 
device.. the first time around but doesn't create the daX node).

The dual firewire/usb2 one works flawlessly all the time (on 4.x and 5.x)

You could try a 'fwcontrol -r' and see what happens.

- -- 
Daniel O'Connor software and network engineer
for Genesis Software -
"The nice thing about standards is that there
are so many of them to choose from."
  -- Andrew Tanenbaum
GPG Fingerprint - 5596 B766 97C0 0E94 4347 295E E593 DC20 7B3F CE8C
Version: GnuPG v1.2.4 (FreeBSD)


More information about the freebsd-current mailing list