World broken in stage 1.1

Barry Bouwsma freebsd-misuser at
Wed Aug 11 02:16:44 PDT 2004

[keep replies to the list and I'll catch up later, thanks]

> > Well, happy POLA violation to you too; this worked until now.  Please
> > add text to make.conf explaining the new order.

> Can you prove that it worked?  I tried to no avail with the old
> (August 1 2004, before the changes) make(1) and MAKEOBJDIRPREFIX
> set in /etc/make.conf, to try to buildworld, and it always fails.

I used to set this in make.conf, but only as
Lately I haven't been building normally (doing exclusively
crossbuilds, with commandline scripts where I explicitly
set env variables), but I should try migrating things back
into the specified make.conf for a test build.

> It fails for me because MAKEOBJDIRPREFIX from /etc/make.conf (a
> global variable) overrides the value of the MAKEOBJDIRPREFIX

It probably had succeeded for me due to using `?=' rather
than just the `=' which would result in the failures most
people see.

> Trying to set MAKEOBJDIRPREFIX in /etc/make.conf and attempting to buildworld
> RELENG_4 on a 4.x machine similarly fails right away.

I had been doing this in the past, but as noted, not recently.
I'll try it again Real Soon Now.

> The reason I'm writing this email is that I'm really interested in
> reproducing the case where it could have possible worked before.  Any help

A world build takes days on my machines, but I promise that
the next ones I kick off, I'll use the make.conf setting as
much as possible.  If it's expected to work with `?=',
though, then ignore me.

I agree that even if it does work with `?=', that too many
people will fail to see the difference between that and a
plain `=' and use the latter.  However, I do like that it
(used to?) work from make.conf, for times when I forget to
set the environment variable.

Which brings up something else -- has there been any
resolution of the conflict between `DISTDIR' as used by
ports, and `DISTDIR' as used by the `distribute' targets?
I have the former set in my make.conf, which resulted in
some odd paths, no matter how I specified `DESTDIR=' and
`DISTDIR=' as both environment and `make' options when in
the top-level src directory, but resolved itself only when
given as an option within the `etc' subdirectory.

Not that I know how to use `distribute/distribution' at
all, but I saw that as one way to populate DESTDIR/etc.

(Shoot me if this has been resolved in a way I've failed
to catch during the months spent offline.)

barry bouwsma

More information about the freebsd-current mailing list