updating a Athlon XP 2200 signal 4's everywhere

Doug White dwhite at gumbysoft.com
Mon Apr 26 10:40:08 PDT 2004

On Tue, 20 Apr 2004, edwinculp wrote:

> On April 17 I tried updating an Athlon XP from a current
> built at the end of february or the begining of march.
> Cvsup, buildworld, installworld, buildkernel, installkernel
> worked fine.  I didn't reboot and test the installation and
> on April 18 resup'ed and repeated the process - bad idea --
> everything built except the kernel and now I am getting
> signal 4 dumps on fsck, sysctl, df, ps, dd, etc.  I can't
> remember ever having signal 4 problems.  I built a new
> release on Sunday night on another machine, burned a CD and
> tried doing a new install but it wouldn't write to the disk.
> (maybe the reported entropy problem) I did an update to
> April 18 but it still has the same signal 4 problem.

Make sure you don't have a bogus CPU type set in /etc/make.conf.

Signal 4 = SIGILL for people not paying attention.

Doug White                    |  FreeBSD: The Power to Serve
dwhite at gumbysoft.com          |  www.FreeBSD.org

More information about the freebsd-current mailing list