updating a Athlon XP 2200 signal 4's everywhere

edwinculp edwinculp at prodigy.net.mx
Tue Apr 20 04:25:42 PDT 2004

On April 17 I tried updating an Athlon XP from a current
built at the end of february or the begining of march. 
Cvsup, buildworld, installworld, buildkernel, installkernel
worked fine.  I didn't reboot and test the installation and
on April 18 resup'ed and repeated the process - bad idea --
everything built except the kernel and now I am getting
signal 4 dumps on fsck, sysctl, df, ps, dd, etc.  I can't
remember ever having signal 4 problems.  I built a new
release on Sunday night on another machine, burned a CD and
tried doing a new install but it wouldn't write to the disk.
(maybe the reported entropy problem) I did an update to
April 18 but it still has the same signal 4 problem.

I would certainly appreciate any suggestions as to what
could cause the signal 4 dump.  Could it be a hardware issue
or could I have library issues between the versions?

Thanks for your help,


More information about the freebsd-current mailing list