[Evil project] / ibm thinkpad t41

jason kawaja kawaja at ece.ufl.edu
Fri Apr 23 06:04:51 PDT 2004

On Fri, 23 Apr 2004, Yann Berthier wrote:

> On Thu, 22 Apr 2004, jason kawaja wrote:
> > actually, other users have just got this working.  however i notice
> > yet another change at :
>    I know that, this is what i find puzzling: either this is a problem
>    specific to my laptop model, or specific to ... me ;)
> >  http://www.freebsd.org/cgi/cvsweb.cgi/src/sys/dev/if_ndis/if_ndis.c
> >
> > that was made after the rest of us got it working.  which one are you
> > using? 1.55 or 1.56?
>    rev 1.55. But no revision of if_ndis worked for me, never, ever. it
>    always hung whenever i tried to load if_ndis.ko

as others have mentioned/nudged, verify your exact card and report back
to the list.

fwiw, below is what pciconf reports as my centrino before loading ndis
and if_ndis modules :

 none3 at pci2:2:0: class=0x028000 card=0x25518086 chip=0x10438086 rev=0x04

after loading ndis and if_ndis the none3 label is replaced with ndis0.

Jason Kawaja

More information about the freebsd-current mailing list