device uscanner in GENERIC?

Chris chris at
Tue Apr 20 07:09:48 PDT 2004

I like to understand. I did nothing to get the scanner to work with root.

I agree with you, I use FreeBSD as a desktop systema as well as a 
server, making it as simple as possible will help newbies and omprove 
the FreeBSD experiance.  I have had some printing issues with a parallel 
printer (CUPS and LPD did not work as easily as 4.x) and a few sound 
issues namely with KDE 3.2, the scanner has worked without a flaw. It's 
a cheapo Epson Perfection 1260. I had an HP a while back which I could 
not get to work, that one cost a lot more, but this $100 piece of gold 
of a scanner is slow but sure.

Since you did not mention any details I did not understand where you 
were having problems.

I had to change the permissions to let my kids access to it....otherwise 
it was plug and play.


Mattias Schlenker wrote:

> Chris wrote:
>> I did not have to recompile my kernel for my USB scanner to work and 
>> I am using uscanner.
>> 5.1 5.2 both worked.
> This may be... But many -- especially many cheap -- scanners nowadays 
> work better with ugen/libusb or even just work with ugen/libusb. So 
> removing "device uscanner" from GENERIC would mean that someone like 
> you who *wants* to use uscanner has to load uscanner.ko, which is far 
> less work than recompiling the kernel.
> In 4.x it worked perfectly for all sides. Removing "device uscanner" 
> from GENERIC would result in a situation that is more close to the 
> situation with 4.x than the situation today is.
> Thanks
> Matt

More information about the freebsd-current mailing list