em0 on install

Peter Schuller peter.schuller at infidyne.com
Sun Nov 23 18:17:32 PST 2003


> >> trying to install using the 5.1-release mini cd and em0.  it seems not
> >> to dhcp (looked with tcpdump) despite my saying Yes (and no to ipv6).
> >> am i missing a clue?

[snip]

> this is a thinkpad t40p.  4.9-release cdrom boots through to em0
> media just fine, and i just retested that assertion without moving
> any wires etc.

I have seen this on the T40p. The "solution" is to disable the cardbus 
support.

I have detailed my experience with this laptop at 

   http://www.scode.org/freebsdt40p.html

The relevant part is this:

"The gigabit ethernet interface - em0 - worked perfectly during installation. 
When I booted the resulting system however, it no longer worked. The driver 
failed to load properly during boot with an error regarding the EEPROM 
checksum being invalid. I found this post which indicated the em0 driver 
"broke" support on the X31 somewhere between 5.0-RELEASE and 5.1-RELEASE. I 
tried using the old 5.0 driver in 5.1, aswell as removing the checksum check 
in the 5.1 driver. No luck. I eventually figured out that the pcmcia support 
seemed to break just about everything, including the em driver. When the 
cardbus bridge (cdb) was commented out in the kernel configuration, em0 
suddenly worked perfectly. So basically, a good idea in general is to strip 
down unused stuff in the kernel configuration, but specifically the cardbus 
bridge. "

This is the post referenced in the above paragraph:

   http://lists.freebsd.org/pipermail/freebsd-i386/2003-June/000047.html

(note: i'm not on -current, so please CC any responses that are meant for me 
to respond to, thanks!)

-- 
/ Peter Schuller, InfiDyne Technologies HB

PGP userID: 0xE9758B7D or 'Peter Schuller <peter.schuller at infidyne.com>'
Key retrieval: Send an E-Mail to getpgpkey at scode.org
E-Mail: peter.schuller at infidyne.com Web: http://www.scode.org




More information about the freebsd-current mailing list