Recent -current hangs on Tyan S2460 before finishing boot

John Baldwin jhb at FreeBSD.org
Thu Nov 13 09:58:55 PST 2003


On 13-Nov-2003 Benjamin Lewis wrote:
> On November 13 2003, John Baldwin wrote:
> 
>> 
>> On 13-Nov-2003 Benjamin Lewis wrote:
> 
> [trouble booting -current on Tyan Tiger MP]
> 
>> Can you do a 'show intrcnt' from the ddb prompt?  It sounds like you
>> may be getting an interrupt storm due to a mis-routed PCI interrupt.
> 
> I didn't see any unexpectedly large numbers, but IRQ 15 isn't in the
> list:
> 
> [...]
> GEOM: create disk ad0 dp=0xc2e19370
> ad0: 57241MB <WDC WD600AB-00BVA0> [116301/16/63] at ata0-master UDMA100
> Waiting 10 seconds for SCSI devices to settle
> [halt - sent]
> Stopped at      siointr1+0xec:  jmp     siointr1+0x220
> db> show intrcnt
> irq4: sio0              2
> irq8: rtc               1725
> irq13: npx0             1
> stray irq13             1
> irq14: ata0             17
> irq19: ohci0 ahc0       1
> irq0: clk               1
> db> cont
> [halt - sent]
> Stopped at      siointr1+0xec:  jmp     siointr1+0x220
> db> show intrcnt
> irq4: sio0              4
> irq8: rtc               3407
> irq13: npx0             1
> stray irq13             1
> irq14: ata0             17
> irq19: ohci0 ahc0       1
> irq0: clk               1
> db> cont
> [halt - sent]
> Stopped at      siointr1+0xec:  jmp     siointr1+0x220
> db> show intrcnt
> irq4: sio0              6
> irq8: rtc               7418
> irq13: npx0             1
> stray irq13             1
> irq14: ata0             17
> irq19: ohci0 ahc0       1
> irq0: clk               1
> db> 

You aren't getting any clock interrupts it seems.  Very weird.  Can
you try using NO_MIXED_MODE instead?  I still think the ata1 is bogus,
but I don't think that is causing your hang now.

-- 

John Baldwin <jhb at FreeBSD.org>  <><  http://www.FreeBSD.org/~jhb/
"Power Users Use the Power to Serve!"  -  http://www.FreeBSD.org/


More information about the freebsd-current mailing list