Radeon DRM-Problem

Ralf Folkerts ralf_folkerts at gmx.de
Tue Nov 11 11:37:51 PST 2003

Hi John,

> Actually, try adding an 'AGPSize' option in the 'Device' section with a
> set to the size of your aperture.  I Think X uses a 1mb aperture by
> and it may be that it is failing to allocate some buffers due to your
> resolution combined with the small default size of the aperture.
> Adding 'AGPMode 4' probably couldn't hurt as well.

I just tried that (added both AGPSize and AGPMode) . However, I still
get the same error :-(

agp0: binding memory at bad offset 0
error: [drm:pid658:radeon_cp_init] *ERROR* radeon_cp_init called without
lock held
error: [drm:pid658:radeon_unlock] *ERROR* Process 658 using kernel context 0

I also attached the XFree86.0.log...

Do you have any more hints? If not I'd just wait a bit and see if this

-------------- next part --------------
A non-text attachment was scrubbed...
Name: XFree86.0.log_Penguin
Type: application/octet-stream
Size: 37858 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-current/attachments/20031111/e5279f0c/XFree86.0-0001.obj

More information about the freebsd-current mailing list