FreeBSD-CURRENT kernel hangs on starting KDE

TamásR. freddy at
Sat Nov 8 04:38:47 PST 2003

On Saturday 01 November 2003 23.25, you wrote:
> > System: FreeBSD 5.1-CURRENT i386
> >
> > Relevant hardware config:
> > Mainboard  : ASUS P4S533-E (SIS645DX north, SIS962/L south bridges)
> > Memory     : PC2700 512MB DDR RAM (memtest86 tested)
> > VGA card   : ATI RADEON 9000 PRO
> I had similar lockups with a SuperMicro P6DGH (dual PIII/850)/ATI All-in
> Wonder (RADEON 7200)/Intel Pro100+ which were solved by moving the
> Ethernet card to another IRQ (it was configured to share 11 by default,
> moved it to 9).  The system would just stop working - mouse frozen, no
> keyboard response, etc.
> I use KDE, also.
> Mike Squires

Thanks for your answer. I've examined my interrupt configuration
and as it sees from the booting log the UDMA controller shares the
IRQ with the VGA card:
drm0: <ATI Radeon If R250 9000> port 0xd800-0xd8ff mem 0xe7800000-0xe780ffff,0xf8000000-0xfbffffff irq 11 at device 0.0 on pci1
atapci0: <SiS 962 UDMA133 controller> port 0xa400-0xa40f,0xa800-0xa803,0xb000-0xb007,0xb400-0xb403,0xb800-0xb807 irq 11 at device 2.5 on pci0

Ethernet uses a quite different IRQ, altough I've tried to turn off
the sound card/ethernet cards built-in my mainboard (I have two
ethernet cards) freeing some IRQ lines, that didn't help. I've tried
to configure my VGA card and UDMA controller to allocate another
IRQ through BIOS and /boot/device.hints but they always use the
same IRQ line regardless any setting. Should I recompile the kernel
with a new device.hints? Yesterday I synced the source tree and
tested the newest kernel, which hung similarly at starting KDE.
Anyway the lastest kernel, which worked (compiled on 25. of Sept.)
had no any problem with the IRQ-s but since then I cannot even
compile any working kernel with KDE... I'm sure there is no problem
with my hardware.

I would do appreciate any help.

Thanks in advance,
Tamás R.

More information about the freebsd-current mailing list