FreeBSD-CURRENT kernel hangs on starting KDE

Q q_dolan at yahoo.com.au
Sun Nov 2 15:54:20 PST 2003


You can use ident(1) to extract the CVS version numbers of the files
that were used to compile your respective kernels.

Try this for a list of files and their respective versions:
'ident /boot/kernel/kernel /boot/kernel.old/kernel | sort'

Seeya...Q

On Sun, 2003-11-02 at 08:07, Tamás R. wrote: 

> I'm sorry for my previous e-mail, I hope it will look better :)
> 
> Some months ago I installed a FreeBSD-current system on my
> desktop computer. I use the KDE desktop environment and I
> compiled really everything from ports. I periodically maintain it
> so my system is up-to-date. I have been experiencing a problem
> with FreeBSD-current kernel all the time. Some months ago I
> tried to compile a custom kernel based on GENERIC commenting
> out the not necessary hardwares from my config, like RAID and
> most of NICs, etc. (I think it is a general thing when customizing).
> Although I haven't tested it too much the kernel booted properly
> and everything worked good in console. Trying to start KDE caused
> system crash (I guess in kernel level). I have spent long days to
> find the reason trying almost all combination of kernel config
> settings without luck. Ok, but GENERIC is worked with some
> custom lines added to it (but I couldn't remove anything except
> debugging). Since 25th of September something changed in the
> current kernel source tree because I am not able to compile any
> kernel, even GENERIC, with which KDE would start without freezing
> the whole machine partly or completely. Unfortunately I did not
> preserve any earlier source tree version, I just upgraded it with
> cvsup before the compilations. Now I use a newer base system than
> the kernel, which results in an unstable operation (it is normal
> I guess), because I only preserved the lastest goog-working
> /boot/kernel binaries I compiled before.
> 
> "KDE freezing" in detail
> --
> System: FreeBSD 5.1-CURRENT i386
> 
> Relevant hardware config:
> Mainboard  : ASUS P4S533-E (SIS645DX north, SIS962/L south bridges)
> Memory     : PC2700 512MB DDR RAM (memtest86 tested)
> VGA card   : ATI RADEON 9000 PRO
> 
> Very recent FreeBSD-current GENERIC kernel (was compiled exaclty
> as described in the handbook) completely freezes some seconds later
> after starting KDE. Input peripherials/ACPI button become unusable
> and the machine does not respond to ICMP on LAN so it completely
> hangs. It is not thought a hardware failure because earlier kernel
> with the same config (synced with cvsup on 25th Sept. 2003) works
> very good. KDE and XFree86 were compiled from the lastest ports so
> they are up-to-date. Logs does not show any usable information
> related to this freezing so I think there is no point to attach any
> of them here (XFree86 just stops logging before some radeondrm
> messages would be logged in normal case). I guess so it is closely
> an ATI-driver related problem because when I tested the same base
> system/kernel with an S3Trio VGA card that worked and the ATI did
> not. This ATI is a common card (with dual head+tv output) and not a
> cheap one at all (I currently use it on other OS-es on the same
> machine without experiencing any problems).
> 
> Since I have been experiencing these problems I sync my source tree
> more times a week and I'm trying to compile a working kernel without luck.
> 
> Note: If I switch back to console immediately after X server
> started and before KDE begins to initialize then KDE starts up
> properly. When I go back to X again I see the desktop as everything
> would be right. Some seconds later the same freezing takes place.
> First the keyboard blocks, then the mouse starts clogging and the
> whole machine totally hangs.
> 
> 
> I would appreciate any help in connection with this problem's solution.
> 
> Thanks in advance,
> Tamás R.
> _______________________________________________
> freebsd-current at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-current
> To unsubscribe, send any mail to "freebsd-current-unsubscribe at freebsd.org"


More information about the freebsd-current mailing list