sysinstall issues (was Re: Toshiba Portege R100: 5.1-JPSNAP install CD hangs)

Takayama Fumihiko tekezo at
Wed Nov 5 16:13:20 PST 2003


> >>booting a Toshiba Portege R100 off Wednesday's 5.1-JPSNAP install CD 
> >>hangs early during the boot, with or without ACPI. It may be related to 
> >>probing the graphics chip, see the attached snapshot.
> >>
> >R100 has problem with PnP for FreeBSD. 
> >My Toshiba Portege R100 on FreeBSD 5.1-RELEASE can boot by below process.
> >
> >1) enter BIOS setup (booting with press ESC) 
> >2) [Device Config] change to "All Devices" from "Setup by OS"
> Thank you very much, Fumihiko-san, that solved the booting problem!
> However, I was still unable to install 5.1-JPSNAP on the machine. With 
> the BIOS settings you suggested, I managed to get to sysinstall. After 
> specifying the desired install setting, sysinstall refuses to install, f
> claiming it did not detect a CD/DVD drive?
> The drive in question is detected during boot as:
> umass0: NewAge International STORIX Optical Series, rev 2.00/0.01
> (see
> Can sysinstall not install off of USB drives?
In my case using "NOVAC CD-R/RW Station for USB", 
very very slow data transfer (maybe using USB 1.1 but 2.0), 
so I actually install FreeBSD from FTP. 
CD-ROM installing is impractical, though possible. 

[this page is written by Japanese])

> To circumvent this issue, I copied the install CD contents onto a local 
> FTP server, and tried a network install. After contacting the server and 
> formatting the partition, sysinstall panic'ed died with an ffs panic. A 
> snapshot of the traceback is here: 
Umm, I got this error by update install, not clean install. 

> Any ideas on how to pull -current onto this laptop, other then 
> installing -stable and compiling from scratch?
"5.1-RELEASE installing first, then cvsup to -current" is better, I think...
(My laptop works fine by this step). 


Takayama Fumihiko <tekezo at>

More information about the freebsd-current mailing list