sysinstall issues (was Re: Toshiba Portege R100: 5.1-JPSNAP install CD hangs)

Lars Eggert larse at ISI.EDU
Wed Nov 5 13:47:34 PST 2003

Takayama Fumihiko wrote:
>>booting a Toshiba Portege R100 off Wednesday's 5.1-JPSNAP install CD 
>>hangs early during the boot, with or without ACPI. It may be related to 
>>probing the graphics chip, see the attached snapshot.
>>I've also attached the 4.9 dmesg - 4.9 boots fine off its install CD - 
>>in case that helps.
>>Any ideas?
> R100 has problem with PnP for FreeBSD. 
> My Toshiba Portege R100 on FreeBSD 5.1-RELEASE can boot by below process.
> 1) enter BIOS setup (booting with press ESC) 
> 2) [Device Config] change to "All Devices" from "Setup by OS"

Thank you very much, Fumihiko-san, that solved the booting problem!

However, I was still unable to install 5.1-JPSNAP on the machine. With 
the BIOS settings you suggested, I managed to get to sysinstall. After 
specifying the desired install setting, sysinstall refuses to install, 
claiming it did not detect a CD/DVD drive?

The drive in question is detected during boot as:

umass0: NewAge International STORIX Optical Series, rev 2.00/0.01

Can sysinstall not install off of USB drives?

To circumvent this issue, I copied the install CD contents onto a local 
FTP server, and tried a network install. After contacting the server and 
formatting the partition, sysinstall panic'ed died with an ffs panic. A 
snapshot of the traceback is here:

Any ideas on how to pull -current onto this laptop, other then 
installing -stable and compiling from scratch?

Lars Eggert <larse at>           USC Information Sciences Institute
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3529 bytes
Desc: S/MIME Cryptographic Signature
Url :

More information about the freebsd-current mailing list