errors using wi driver in -CURRENT

Soeren Schmidt sos at
Wed Jul 16 07:28:15 PDT 2003

It seems Bruce Cran wrote:

Just to chime in here, I've spent 2 weeks of various trial and errors
to get two Lucent Wavelan's (one 4.8, one -current) to talk to each other.
Dispite my more or less futile experiments this would not work no
matter what (even asking on -mobile and trying what came up there didn't help).

Since I can use the cards perfectly between two 4.8 boxes (and have
been for about 2 years), my take is that the wi driver in -current is
borked useless, at least for some cards (It worked in 5.0 but broke on
the way to 5.1 IIRC).

just my .01 EUR...

> I've just reinstalled a 'desktop server' from FreeBSD 4.8 to -CURRENT, and
> am finding quite a few problems with the 802.11b driver.    I'm trying to use
> it as a access point, so I've tried setting the flag0,adhoc mediaopt, since
> ibss-master which I had used under 4.8 didn't work.  This appeared to work,
> but other computers couldn't connect.   Now, using just 'adhoc' other
> computers can connect, but whenever any use the network, the rate shown in
> 'ifconfig wi0' drops to 2MBit/s and I only get about 100KB/s bandwidth.  Also,
> whenever I try to reset the media and/or mediaopt settings using eg
> 'ifconfig wi0 media DS/11Mbps mediaopt adhoc', the driver or card seems
> to go a bit buggy, with messages like:
> wi0: bad alloc 2f2 != 1f7, cur 0 nxt 0
> wi0: device timeout
> wi0: device timeout
> wi0: timeout in wi_cmd 0x0021; event status 0x0008
> when I run 'ifconfig' wi0 output stalls for a few seconds, locking the system,
> while another kernel error message appears.   I'm using the card with a 
> PCI converter card, and the card itself is:
> wi0: <MELCO WLI-PCM-L11> at port 0x100-0x13f irq 11 function 0 config 1 on 
> pccard0
> wi0: 802.11 address: 00:01:02:03:04:05
> wi0: using Lucent Technologies, WaveLAN/IEEE
> wi0: Lucent Firmware: Station (8.36.1)
> wi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
> on initial configuration, the Media line of ifconfig is:
> media: IEEE 802.11 Wireless Ethernet DS/11Mbps <adhoc> (none)
> when I was recently getting ~35KB/s to the card, the 'OACTIVE' flag on the 
> interface was set.
> I can provide more information which can help in diagnosing the problem, if
> required.
> --
> Bruce Cran
> _______________________________________________
> freebsd-current at mailing list
> To unsubscribe, send any mail to "freebsd-current-unsubscribe at"


More information about the freebsd-current mailing list