usb mouse on ehci controller doesn't work

Bruce Cran bruce at
Sun Jul 6 04:54:24 PDT 2003

On Sun, Jul 06, 2003 at 01:21:47AM -0700, Doug White wrote:
> On Sat, 5 Jul 2003, Bruce Cran wrote:
> > I'm sure I used to be able to use a usb mouse in earlier versions of FreeBSD,
> > but now whatever I try, I just can't get the secondary mouse (or primary, if
> > I don't configure the laptop mouse pad) to work.  When
> > I plug it in, it finds it and allocates it to /dev/ums0 (ums0: Logitech
> > USB Receiver, rev 1.10/13.10, addr 2, iclass 3/1.  ums0:  5 buttons and Z dir)
> >  but XFree86 doesn't seem to like it - the log file
> Dying on a fcntl O_ASYNC, strange.
> > is attached.  Also, moused doesn't show the
> > pointer when I run 'moused -p /dev/ums0 -t auto'.
> I can confirm that my wired mx300 mouse with a Hi-speed USB machine works
> fine. Note that it shouldn't be attaching to ehci but to the underlying
> controller, uhci most likely.  'usbdevs' will show you the device tree.
> Are you doing 'vidcontrol -m on' to enable the mouse in the current vty?

I swapped the Logitech wireless mouse for a Microsoft Intellimouse optical,
and this time had slightly more success.   If I run moused and tell XFree86
to use both /dev/psm0 and /dev/sysmouse, it still dies with the fcntl error.
However, if I'm only using /dev/sysmouse, it works perfectly.  The kernel has
uhci but not ehci compiled in, so it must indeed be using the low-speed
driver, not ehci.  If I don't run moused but just tell X11 to use /dev/ums0,
it still fails with the fcntl error.

Bruce Cran

More information about the freebsd-current mailing list