usb mouse on ehci controller doesn't work

Doug White dwhite at
Sun Jul 6 01:21:47 PDT 2003

On Sat, 5 Jul 2003, Bruce Cran wrote:

> I'm sure I used to be able to use a usb mouse in earlier versions of FreeBSD,
> but now whatever I try, I just can't get the secondary mouse (or primary, if
> I don't configure the laptop mouse pad) to work.  When
> I plug it in, it finds it and allocates it to /dev/ums0 (ums0: Logitech
> USB Receiver, rev 1.10/13.10, addr 2, iclass 3/1.  ums0:  5 buttons and Z dir)
>  but XFree86 doesn't seem to like it - the log file

Dying on a fcntl O_ASYNC, strange.

> is attached.  Also, moused doesn't show the
> pointer when I run 'moused -p /dev/ums0 -t auto'.

I can confirm that my wired mx300 mouse with a Hi-speed USB machine works
fine. Note that it shouldn't be attaching to ehci but to the underlying
controller, uhci most likely.  'usbdevs' will show you the device tree.

Are you doing 'vidcontrol -m on' to enable the mouse in the current vty?

> Has something in the ums driver changed that X11 doesn't like, or have I
> not configured something. Could it be that I've always used it on a
> computer with USB1 and there's something about the usb2 I've now got
> that the logitech controller doesn't like?  The lines from XF86Config
> are:

Have you tried using moused + xfree86?

Doug White                    |  FreeBSD: The Power to Serve
dwhite at          |

More information about the freebsd-current mailing list