Can't connect to wireless network with recent -CURRENT

Harti Brandt brandt at
Thu Jul 3 00:32:27 PDT 2003

On Thu, 3 Jul 2003, Greg 'groggy' Lehey wrote:

GgL>I've just upgraded my laptop to a recent -CURRENT, and since then I've
GgL>been having a lot of network problems.  Here's a rough chronology:
GgL>- Machine is a Dell Inspiron 7500, which I've been using with releases
GgL>  4 and 5 of FreeBSD without problems for the last 3 years.  It's
GgL>  usually connected to my house 802.11b network, which is run by an
GgL>  old 486 in ad-hoc mode, no WEP.  I use DHCP to set up the
GgL>  connection.
GgL>- Things worked fine up to my last kernel:
GgL>  Jun 26 14:03:43 kondoparinga kernel: FreeBSD 5.0-CURRENT #0: Sun May 11 13:25:03 CST 2003
GgL>- On 28 June, I upgraded to the then -CURRENT.  I had a lot of trouble
GgL>  getting things working, including the following from the gateway
GgL>  machine:
GgL>   Jun 29 09:35:15 air-gw dhcpd: DHCPREQUEST for from 00:02:2d:04:09:3a via wi0
GgL>   Jun 29 09:35:15 air-gw dhcpd: DHCPACK on to 00:02:2d:04:09:3a via wi0
GgL>   Jun 29 09:35:16 air-gw dhcpd: DHCPDECLINE on from 00:02:2d:04:09:3a via wi0
GgL>   Jun 29 09:35:16 air-gw dhcpd: Abandoning IP address declined.
GgL>   Jun 29 09:35:16 air-gw dhcpd: DHCPDISCOVER from 00:02:2d:04:09:3a via wi0
GgL>   Jun 29 09:35:16 air-gw dhcpd: DHCPOFFER on to 00:02:2d:04:09:3a via wi0
GgL>  Nothing was mentioned in the log files on the laptop.
GgL>- I managed to connect, however, and things worked for a while, but
GgL>  the machine kept freezing.  I tried with a 100 Mb/s Ethernet card,
GgL>  and it had problems too.  With both network cards, it reported
GgL>  various error messages which I didn't write down because I thought
GgL>  they would be logged; unfortunately they weren't.  The one from wi0
GgL>  is still occurring:
GgL>      wi0: bad alloc 3b4 != ff, cur 0 nxt 0
GgL>- I built a new kernel and world on 1 July.  Since then I haven't had
GgL>  any trouble with the system freezing up, but and was no longer able
GgL>  to connect at all with the wireless card.  After booting, I get:
GgL>        inet6 fe80::202:2dff:fe04:93a%wi0 prefixlen 64 scopeid 0x3
GgL>        inet netmask 0xff000000 broadcast
GgL>        ether 00:02:2d:04:09:3a
GgL>        media: IEEE 802.11 Wireless Ethernet autoselect (DS/2Mbps)
GgL>        status: associated
GgL>        ssid Netname 1:Netname
GgL>        stationname "FreeBSD WaveLAN/IEEE node"
GgL>        channel 3 authmode OPEN powersavemode OFF powersavesleep 100
GgL>        wepmode OFF weptxkey 1
GgL>   However, no traffic comes through.
GgL>It's pretty clear that it's this laptop: I have other machines on the
GgL>net which work without problems, and this machine also works if I boot
GgL>it with 4.8-STABLE.
GgL>Any thoughts?

I think the same problem was reported by Rob Holmes two weeks ago and by
me (although with lesser detail) yesterday. I converted my kernel from
OLDBUS to NEWBUS and now one out of four or five tries the card works, but
this is really annoying. I have an Inspiron 8200 and an Avaya (that is a
Lucent) card. I have found no solution until now.

harti brandt,
brandt at, harti at

More information about the freebsd-current mailing list