Can't connect to wireless network with recent -CURRENT

Greg 'groggy' Lehey grog at
Wed Jul 2 20:25:50 PDT 2003

I've just upgraded my laptop to a recent -CURRENT, and since then I've
been having a lot of network problems.  Here's a rough chronology:

- Machine is a Dell Inspiron 7500, which I've been using with releases
  4 and 5 of FreeBSD without problems for the last 3 years.  It's
  usually connected to my house 802.11b network, which is run by an
  old 486 in ad-hoc mode, no WEP.  I use DHCP to set up the

- Things worked fine up to my last kernel:

  Jun 26 14:03:43 kondoparinga kernel: FreeBSD 5.0-CURRENT #0: Sun May 11 13:25:03 CST 2003

- On 28 June, I upgraded to the then -CURRENT.  I had a lot of trouble
  getting things working, including the following from the gateway

   Jun 29 09:35:15 air-gw dhcpd: DHCPREQUEST for from 00:02:2d:04:09:3a via wi0
   Jun 29 09:35:15 air-gw dhcpd: DHCPACK on to 00:02:2d:04:09:3a via wi0
   Jun 29 09:35:16 air-gw dhcpd: DHCPDECLINE on from 00:02:2d:04:09:3a via wi0
   Jun 29 09:35:16 air-gw dhcpd: Abandoning IP address declined.
   Jun 29 09:35:16 air-gw dhcpd: DHCPDISCOVER from 00:02:2d:04:09:3a via wi0
   Jun 29 09:35:16 air-gw dhcpd: DHCPOFFER on to 00:02:2d:04:09:3a via wi0

  Nothing was mentioned in the log files on the laptop.

- I managed to connect, however, and things worked for a while, but
  the machine kept freezing.  I tried with a 100 Mb/s Ethernet card,
  and it had problems too.  With both network cards, it reported
  various error messages which I didn't write down because I thought
  they would be logged; unfortunately they weren't.  The one from wi0
  is still occurring:

      wi0: bad alloc 3b4 != ff, cur 0 nxt 0

- I built a new kernel and world on 1 July.  Since then I haven't had
  any trouble with the system freezing up, but and was no longer able
  to connect at all with the wireless card.  After booting, I get:

        inet6 fe80::202:2dff:fe04:93a%wi0 prefixlen 64 scopeid 0x3 
        inet netmask 0xff000000 broadcast
        ether 00:02:2d:04:09:3a
        media: IEEE 802.11 Wireless Ethernet autoselect (DS/2Mbps)
        status: associated
        ssid Netname 1:Netname
        stationname "FreeBSD WaveLAN/IEEE node"
        channel 3 authmode OPEN powersavemode OFF powersavesleep 100
        wepmode OFF weptxkey 1

   However, no traffic comes through.  

It's pretty clear that it's this laptop: I have other machines on the
net which work without problems, and this machine also works if I boot
it with 4.8-STABLE.

Any thoughts?

Finger grog at for PGP public key
See complete headers for address and phone numbers
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-current mailing list