misc/181918: GEOM: gmirror label (-h) doesn't cause /dev/mirror/ population or activation

Charlie R 3zstbn24xn at snkmail.com
Sat Sep 7 20:40:00 UTC 2013


>Number:         181918
>Category:       misc
>Synopsis:       GEOM: gmirror label (-h) doesn't cause /dev/mirror/ population or activation
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    freebsd-bugs
>State:          open
>Quarter:        
>Keywords:       
>Date-Required:
>Class:          sw-bug
>Submitter-Id:   current-users
>Arrival-Date:   Sat Sep 07 20:40:00 UTC 2013
>Closed-Date:
>Last-Modified:
>Originator:     Charlie R
>Release:        9.2/amd64
>Organization:
None
>Environment:
FreeBSD localhost 9.2-RC2 FreeBSD 9.2-RC2 #0 r254368: Thu Aug 15 18:49:04 UTC 2013     root at bake.isc.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

>Description:
I try:

  $ gmirror label -h mymirror /dev/zvol/pool/component0.eli /dev/zvol/pool/component1.eli 

And nothing appears in /dev/mirror/.  I can confirm that "gmirror dump" shows metadata there.  But the mirrored setup isn't actually constructed so I can't use it.  It's also unclear to me how to best ask the kernel to manually try activating a GEOM label based upon written metadata.  Presently, a "geom activate" has no effect at all - exit status 0 and yet, still, nothing appears in /dev/mirror/.
>How-To-Repeat:
Try to create a gmirror GEOM setup as above.
>Fix:


>Release-Note:
>Audit-Trail:
>Unformatted:


More information about the freebsd-bugs mailing list