bin/160979: 9.0 burncd error caused by change to cd0 from acd0

Gary Palmer gpalmer at freebsd.org
Mon Sep 26 02:32:58 UTC 2011


On Sun, Sep 25, 2011 at 10:10:08AM +0000, Jaakko Heinonen wrote:
> The following reply was made to PR bin/160979; it has been noted by GNATS.
> 
> From: Jaakko Heinonen <jh at FreeBSD.org>
> To: Joe Barbish <fbsd8 at a1poweruser.com>
> Cc: bug-followup at FreeBSD.org
> Subject: Re: bin/160979: 9.0 burncd error caused by change to cd0 from acd0
> Date: Sun, 25 Sep 2011 13:00:43 +0300
> 
>  On 2011-09-24, Joe Barbish wrote:
>  > It seems that in 9.0 the cd/dvd/drive is now given a dev name of cd0 
>  > where in all previous releases it was acd0. 
>  > Tried to use the system burncd command in 9.0 and got this error msg
>  > 
>  > burncd: ioctl(CDRIOCGETBLOCKSIZE): Inappropriate ioctl for device
>  > 
>  > Tested using "burncd -f acd0" and "burncd -f cd0".
>  > In both cases got the same error message.
>  > 
>  > Looks to me like the burncd command needs to be fixed
>  > to work in 9.0. 
>  
>  burncd(8) supports only acd(4) driver. In 9.0 the default is the new
>  CAM-based ATA stack which uses cd(4) (UPDATING entry 20110424).
>  
>  It's unlikely that a support for cd(4) will be added to burncd(8).
>  
>  I think this should be mentioned in release notes.

Can burncd(8) be easily modified to test for a CAM based ATA stack and
output a helpful error message pointing the user at cdrecord?  It would
help avoid more people running into this problem.

Thanks,

Gary


More information about the freebsd-bugs mailing list