bin/160979: 9.0 burncd error caused by change to cd0 from acd0

Fbsd8 fbsd8 at
Sun Sep 25 13:10:07 UTC 2011

The following reply was made to PR bin/160979; it has been noted by GNATS.

From: Fbsd8 <fbsd8 at>
To: Jaakko Heinonen <jh at>
Cc: bug-followup at, freebsd-current at
Subject: Re: bin/160979: 9.0 burncd error caused by change to cd0 from acd0
Date: Sun, 25 Sep 2011 08:44:48 -0400

 Jaakko Heinonen wrote:
 > On 2011-09-24, Joe Barbish wrote:
 >> It seems that in 9.0 the cd/dvd/drive is now given a dev name of cd0 
 >> where in all previous releases it was acd0. 
 >> Tried to use the system burncd command in 9.0 and got this error msg
 >> burncd: ioctl(CDRIOCGETBLOCKSIZE): Inappropriate ioctl for device
 >> Tested using "burncd -f acd0" and "burncd -f cd0".
 >> In both cases got the same error message.
 >> Looks to me like the burncd command needs to be fixed
 >> to work in 9.0. 
 > burncd(8) supports only acd(4) driver. In 9.0 the default is the new
 > CAM-based ATA stack which uses cd(4) (UPDATING entry 20110424).
 > It's unlikely that a support for cd(4) will be added to burncd(8).
 > I think this should be mentioned in release notes.
 Fixing burncd should be a priority, this PR gets it into the "must fix 
 queue" before the next round of beta or RC releases. Yes you have 
 identified what is causing it to not work, but you have not followed 
 through. The next step is to assign it to someone to work on it now. 
 Thats the whole idea of the PR system and beta testing.
 If burncd is not going to work in 9.0 then it should be removed from the 
 release all together. Has any research been done to identify other 
 system commands or ports that changing the system default from acd0 to 
 cd0 effects?

More information about the freebsd-bugs mailing list