kern/144938: [keyboard] [boot] Boot Failure with Apple (MB869LL/A) Keyboard

Warren A. Hunt Jr. hunt at
Sun Mar 21 23:01:56 UTC 2010

Hello Mr. Cran,

Summary:  I don't understand why, but now everything works.

>  Does any more information get displayed with a
>  verbose boot ("boot -v")?

Indeed, it does.  But, now it boots.  Arragh!  Since my
last message, I have re-booted my system at least 10
times, and everything seems to work.  I have re-booted
with regular boot (no "boot -v"), and it works.  I have
powered down and tried again -- and it works.

Six weeks ago, I had this same problem (using this same
Apple keyboard) on another FreeBSD 8.0 system (based on
a SuperMicro "c2sbx" motherboard), which I never
solved.  So, I was worried that somehow Apple's new
keyboard was not supported by FreeBSD 8.0.

For the moment, on my ZOTAC IONITX-A-U board, my
problem has disappeared.  I must have failed to boot
with my Apple keyboard at least 20 times over the last
month.  The only thing I changed was in the BIOS -- I
stopped the "quick boot" sequence, instead specifying
the that the full complement of BIOS tests, such as the
memory test, should be performed.


I'll try it another 20 times or so -- and I'll try
again on my SuperMicro system at work.

Thank you for responding.

And, thank you very much for your hard work on FreeBSD.
I use FreeBSD whenever I can.  I use it as an example
in my classes, and I make sure that my research tools
operate correctly on FreeBSD.



Dr. Warren A. Hunt, Jr.
Department of Computer Science
1 University Station, M/S C0500
The University of Texas
Austin, TX  78712-0233

E-mail:  hunt at
   Tel:  +1 512 471 9748
   FAX:  +1 512 471 8885

More information about the freebsd-bugs mailing list