8.0-RC USB/FS problem

Hans Petter Selasky hselasky at c2i.net
Sun Nov 22 10:45:48 UTC 2009

On Sunday 22 November 2009 05:38:13 Guojun Jin wrote:
> Tried on the USB hard drive:
> Deleted slice 3 and recreated slice 3 with two partitions s3d and s3e.
> Was happy because successfully did dump/restore on s3d, and thought it just
> partition format issue; but system crashed during dump/restore on s3e, and
> partition lost the file system type.
> wolf# mount /dev/da0s3e /mnt
> WARNING: /mnt was not properly dismounted
> /mnt: mount pending error: blocks 35968 files 0
> wolf# fsck da0s3e
> fsck: Could not determine filesystem type
> wolf# bsdlabel da0s3
> # /dev/da0s3:
> 8 partitions:
> #        size   offset    fstype   [fsize bsize bps/cpg]
>   c: 175735035        0    unused        0     0         # "raw" part,
> don't edi t
>   d: 18874368        0    4.2BSD        0     0     0
>   e: 156860667 18874368    4.2BSD        0     0     0
> Therefore, tried directly use fsck_ufs on both USB hard drive and USB stick
> to get file system clean up. All data got back now.
> The machine has run with FreeBSD 6.1 all the way to 7.2 without such
> problem. How can we determine what could go wrong in 8.0? FS or USB.


Error 5 means IO error, so probably the transport layer, USB or lower, is to 

Some things to check:

1) Make sure the connection for your memory stick is Ok.
2) Make sure there is enough power for your memory stick.

Regarding memory sticks:

Other operating systems do a port bus reset when the device has a problem. On 
FreeBSD we just try a software reset via the control endpoint. I guess that it 
is a device problem you are seeing. The USB stack in FreeBSD is faster than 
the old one, and maybe the faster queueing of mass storage requests trigger 
some hidden bugs in your device.

When the problem happens try:

sysctl hw.usb.umass.debug=-1


More information about the freebsd-bugs mailing list