boot2 can't boot from USB?

Craig Rodrigues rodrigc at crodrigues.org
Thu Mar 15 21:43:13 UTC 2007


On Thu, Mar 15, 2007 at 11:16:16AM +0100, Fluffles wrote:
> If so, i may have found some bugs / problems with boot2. Long ago i
> tried to make a bootable USB pendrive with FreeBSD 6.1 on it. It failed
> to boot with the message "invalid slice" and i got a prompt like:

I have worked a lot with getting FreeBSD to boot off of USB devices,
and have gotten it to work.
Specifically, I have worked with USB pen drives, and USB CD-ROM drives.
It *is* possible, but what I have found is the following:
- on some motherboards, you need to explicitly configure the BIOS
  to boot off of a USB device (either a disk, a CD-ROM, or a "Zip drive")
- booting off of USB-CDROM devices seems to be much more reliable than
  booting off of USB pen drives
- if you have an "older" motherboard BIOS, say from about 3-4 years ago,
  booting off of USB devices is more unreliable, than a "newer" motherboard
  BIOS
- if I have 5 different models of USB pen drives, each model may behave
  differently, and may or may not boot.  Same for USB CD-ROM drives,
  but I've found CD-ROM drives to be more reliable than pen drives.

So to summarize: 
- booting off of USB devices seems to be sensitive
  to your motherboard BIOS, and the firmware written into your USB device.
- booting off of USB CD-ROM drives seems to be more reliable than booting
  off of USB pen drives

There is no logic to this, I've just found this out from trial and error,
and banging my head a lot.

-- 
Craig Rodrigues        
rodrigc at crodrigues.org


More information about the freebsd-bugs mailing list