boot2 can't boot from USB?

Fluffles etc at
Thu Mar 15 10:55:21 UTC 2007

Dag-Erling Smørgrav wrote:
> Barry Pederson <bp at> writes:
>> Is there any hope for someday optionally using ZFS as a root filesystem?
> For that to be possible, both /boot/boot2 and /boot/loader need to
> understand ZFS well enough to read files from it.  There isn't much
> room to spare in /boot/boot2, so we'd have to have a separate version
> for ZFS and teach 'disklabel -B' how to pick the right one.

Sorry if this is offtopic. Am i right to assume that:
- boot0 and boot1 both read from the disk via BIOS
- boot2 tries to read from the disk directly, without BIOS

If so, i may have found some bugs / problems with boot2. Long ago i
tried to make a bootable USB pendrive with FreeBSD 6.1 on it. It failed
to boot with the message "invalid slice" and i got a prompt like:

FreeBSD/i386 BOOT
Default: 0:ad(0,a)/boot/loader

Whatever i tried, it fails to load "Loader" or the kernel. Later, i
tried FreeNAS which enables the user to write an image to an USB
pendrive which contains a bootable FreeNAS installation. The copying
went ok, but i got the same boot problem. I then tried it on three
different systems with two different USB pendrives and they all had the
same problem. All of the systems supported USB boot, and it does
actually boot from USB how else could i see that FreeBSD boot prompt?
Some systems are brand new: dualcore SLI motherboards, etc.

It appears to me the boot2 program fails to read from USB. boot0 and
boot1 appear not to have this problem since it uses the BIOS to read
from the disk. Is this correct?
Are USB boot problems by boot2 known, should i file a PR?


- Veronica

More information about the freebsd-bugs mailing list