freebsd 4.11-stable strange problem dl360g4 partial freeze

Christophe Yayon lists at
Wed Aug 3 08:34:48 GMT 2005


I use a ciss 6i (which appears to be supported in man page of ciss)

dmesg :
Copyright (c) 1992-2005 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 4.11-STABLE #0: Tue Aug  2 16:48:11 CEST 2005
    root at
Timecounter "i8254"  frequency 1193182 Hz
CPU: Intel(R) Xeon(TM) CPU 3.60GHz (3600.14-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf41  Stepping = 1
  Hyperthreading: 2 logical CPUs
real memory  = 2147430400 (2097100K bytes)
avail memory = 2088095744 (2039156K bytes)
Changing APIC ID for IO APIC #1 from 0 to 9 on chip
Programming 24 pins in IOAPIC #0
IOAPIC #0 intpin 2 -> irq 0
Programming 24 pins in IOAPIC #1
Programming 24 pins in IOAPIC #2
Programming 24 pins in IOAPIC #3
FreeBSD/SMP: Multiprocessor motherboard: 2 CPUs
 cpu0 (BSP): apic id:  0, version: 0x00050014, at 0xfee00000
 cpu1 (AP):  apic id:  1, version: 0x00050014, at 0xfee00000
 io0 (APIC): apic id:  8, version: 0x00178020, at 0xfec00000
 io1 (APIC): apic id:  9, version: 0x00178020, at 0xfec10000
 io2 (APIC): apic id: 10, version: 0x00178020, at 0xfec82000
 io3 (APIC): apic id: 11, version: 0x00178020, at 0xfec82100
Preloaded elf kernel "kernel" at 0xc035d000.
Warning: Pentium 4 CPU: PSE disabled
Pentium Pro MTRR support enabled
md0: Malloc disk
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Host to PCI bridge> on motherboard
IOAPIC #0 intpin 16 -> irq 2
IOAPIC #0 intpin 19 -> irq 16
IOAPIC #0 intpin 23 -> irq 17
pci0: <PCI bus> on pcib0
pcib1: <PCI to PCI bridge (vendor=8086 device=3595)> irq 2 at device 2.0
on pci0
pci13: <PCI bus> on pcib1
pcib2: <PCI to PCI bridge (vendor=8086 device=3597)> irq 2 at device 4.0
on pci0
pci6: <PCI bus> on pcib2
pcib3: <PCI to PCI bridge (vendor=8086 device=0329)> at device 0.0 on pci6
pci7: <PCI bus> on pcib3
pcib4: <PCI to PCI bridge (vendor=8086 device=032a)> at device 0.2 on pci6
pci10: <PCI bus> on pcib4
pcib5: <PCI to PCI bridge (vendor=8086 device=3599)> irq 2 at device 6.0
on pci0
pci3: <PCI bus> on pcib5
pcib6: <PCI to PCI bridge (vendor=8086 device=25ae)> at device 28.0 on pci0
IOAPIC #1 intpin 0 -> irq 19
IOAPIC #1 intpin 1 -> irq 20
IOAPIC #1 intpin 2 -> irq 21
pci2: <PCI bus> on pcib6
ciss0: <HP Smart Array 6i> port 0x4000-0x40ff mem
0xfdf80000-0xfdfbffff,0xfdff0000-0xfdff1fff irq 19 at device
1.0 on pci2
bge0: <Broadcom BCM5704C Dual Gigabit Ethernet, ASIC rev. 0x2100> mem
0xfdf70000-0xfdf7ffff irq 20 at device 2.
0 on pci2
bge0: Ethernet address: 00:12:79:91:ab:bd
miibus0: <MII bus> on bge0
brgphy0: <BCM5704 10/100/1000baseTX PHY> on miibus0
brgphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,
1000baseTX-FDX, auto
bge1: <Broadcom BCM5704C Dual Gigabit Ethernet, ASIC rev. 0x2100> mem
0xfdf60000-0xfdf6ffff irq 21 at device 2.
1 on pci2
bge1: Ethernet address: 00:12:79:91:ab:bc
miibus1: <MII bus> on bge1
brgphy1: <BCM5704 10/100/1000baseTX PHY> on miibus1
brgphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseTX,
1000baseTX-FDX, auto
uhci0: <UHCI (generic) USB controller> port 0x2000-0x201f irq 2 at device
29.0 on pci0
usb0: <UHCI (generic) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: 2 ports with 2 removable, self powered
uhci1: <UHCI (generic) USB controller> port 0x2020-0x203f irq 16 at device
29.1 on pci0
usb1: <UHCI (generic) USB controller> on uhci1
usb1: USB revision 1.0
uhub1: 2 ports with 2 removable, self powered
pci0: <unknown card> (vendor=0x8086, dev=0x25ab) at 29.4
pci0: <unknown card> (vendor=0x8086, dev=0x25ac) at 29.5
pci0: <USB controller> at 29.7 irq 17
pcib7: <Intel 82801BA/BAM (ICH2) Hub to PCI bridge> at device 30.0 on pci0
IOAPIC #0 intpin 21 -> irq 22
IOAPIC #0 intpin 22 -> irq 23
pci1: <PCI bus> on pcib7
pci1: <ATI Mach64-GR graphics accelerator> at 3.0
pci1: <unknown card> (vendor=0x0e11, dev=0xb203) at 4.0 irq 22
pci1: <unknown card> (vendor=0x0e11, dev=0xb204) at 4.2 irq 23
isab0: <PCI to ISA bridge (vendor=8086 device=25a1)> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel 6300ESB ATA100 controller> port
0x500-0x50f,0x374-0x377,0x170-0x177,0x3f4-0x3f7,0x1f0-0x1f7 irq
 18 at device 31.1 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
eisa0: <EISA bus> on motherboard
mainboard0: <CPQ0741 (System Board)> on eisa0 slot 0
orm0: <Option ROMs> at iomem
0xc0000-0xc7fff,0xc8000-0xcbfff,0xcc000-0xcd7ff,0xee000-0xeffff on isa0
pmtimer0 on isa0
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model Generic PS/2 mouse, device ID 0
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
APIC_IO: Testing 8254 interrupt delivery
APIC_IO: routing 8254 via IOAPIC #0 intpin 2
ata0-slave: ATA identify retries exceeded
SMP: AP CPU #1 Launched!
acd0: CDROM <COMPAQ CD-ROM SN-124> at ata0-master PIO4
Mounting root from ufs:/dev/da0s1a
da0 at ciss0 bus 0 target 0 lun 0
da0: <COMPAQ RAID 1  VOLUME OK> Fixed Direct Access SCSI-0 device
da0: 135.168MB/s transfers
da0: 69459MB (142253280 512 byte sectors: 255H 32S/T 17433C)

and no syslog event ...


> what scsi/sata/ide use ?
> send dmesg ?
> send last syslog event ?
> Regards
> Rmkml
> On Wed, 3 Aug 2005, Christophe Yayon wrote:
>> Date: Wed, 3 Aug 2005 10:01:27 +0200 (CEST)
>> From: Christophe Yayon <lists at>
>> To: freebsd-bugs at, freebsd-hackers at
>> Subject: freebsd 4.11-stable strange problem dl360g4 partial freeze
>> Hi all,
>> I have just installed a new (but good old) freebsd 4.11-stable on a HP
>> DL360G4 and i have a very strange issue : when i do a simple command
>> like
>> 'find /' or 'dmesg' or a 'ls' in a directory with lot of files ; the
>> command is pausing ...
>> I explain, the result of the command begin and afer few result lines, it
>> pausing (like a partial freeze of 1 or 2 seconds) and continue, and
>> pausing again, and then continue...
>> I have tried to recompile a new kernel and world (from stable of
>> yesterday) but i have the same woes. I also try to truss, but no strange
>> messages, no log no kernel messages...
>> I have tried on the same server the 5.4-STABLE (with other disks) and i
>> have not this problem... But i have to install a 4.11 version, because
>> of
>> commercial software... Is it a specific issue with freebsd 4 ?
>> How can i do to debug it ? Do you have any informations about this ?
>> Thanks in advance.
>> _______________________________________________
>> freebsd-hackers at mailing list
>> To unsubscribe, send any mail to
>> "freebsd-hackers-unsubscribe at"

More information about the freebsd-bugs mailing list